Nissan Titan Forum - Search Results
Showing results 1 to 5 of 5
Search took 0.03 seconds.
Search: Posts Made By: Mauro
Forum: General Discussion   12-17-2012, 09:03 AM
Replies: 12
Views: 29,476
Posted By Mauro
Well I did the following things to the truck....

Well I did the following things to the truck. Changed the spark plugs, changed the IPDM relay, changed the evap valve and added the filter kit (all nissan), and the last thing I changed was the fuel...
Forum: General Discussion   11-26-2012, 12:04 PM
Replies: 12
Views: 29,476
Posted By Mauro
I hope I don't have to order the entire module,...

I hope I don't have to order the entire module, but I will be replacing the relay this week and changing the evap. valve that sent the P1446 code. Hopefully by doing this and changing the spark plugs...
Forum: General Discussion   11-25-2012, 04:40 PM
Replies: 12
Views: 29,476
Posted By Mauro
Ok so I made it home ok but the truck did sputter...

Ok so I made it home ok but the truck did sputter a couple of times near the end of my trip. The service engine light came on, I had my scanner in the truck and it read P1446 which from I've read...
Forum: General Discussion   11-23-2012, 07:50 PM
Replies: 12
Views: 29,476
Posted By Mauro
Yes I got power back but I'm just worried that...

Yes I got power back but I'm just worried that tomorrow when I'm going back home it might do it again.
Forum: General Discussion   11-23-2012, 06:34 PM
Replies: 12
Views: 29,476
Posted By Mauro
Loss of power while accelerating.

Looking for your opinion or if you had the same problem. I was doing about 65 while pulling a trailer (2,500 lbs +/-) and suddenly I felt some jerking when I stepped on it to pass slower traffic. It...
Showing results 1 to 5 of 5

 
Forum Jump