Loss of power... Please help - Nissan Titan Forum
Reply
 
Thread Tools Display Modes
post #1 of 19 Old 06-20-2007, 06:54 PM Thread Starter
clwfirefghtnstud
Shift_Newbie
 
clwfirefghtnstud's Avatar
 
Join Date: Aug 2006
Posts: 58
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to clwfirefghtnstud
Loss of power... Please help

so i have noticed a seeming loss of power in the recent months, at first i thought perhaps my k&n was clogged but i only have about 20,000 miles on it and it is relativley clean, my truck is an 04 with 22,000 miles on it, and i am not sure what could account for the loss of throttle response and sluggishness on the excelleration.

i have a 3in cat-back exhaust, the k&n stock replacement filter installed, i removed the plastic tube that extends into the air box ( saw that mod on here thanx guys!!) anybody got any sugestions or insight????

thanx

04' CC LE Deep Water Blue... K&N filter with Air box MOD (CAI & TBS Coming soon!), Totally custom 3in SS exhaust, w/ passenger side exit in front of rear wheel.. Chrome package... front leveling kit.... 0-60 faster than you can say hemi ha ha ha
clwfirefghtnstud is offline  
Sponsored Links
Advertisement
 
post #2 of 19 Old 06-20-2007, 06:56 PM
Tricky-Dick
Shift_Hardcore
 
Tricky-Dick's Avatar
 
Join Date: Oct 2005
Location: Texas...Where Else? ®TM
Posts: 1,853
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Cool

Quote:
Originally Posted by clwfirefghtnstud
so i have noticed a seeming loss of power in the recent months, at first i thought perhaps my k&n was clogged but i only have about 20,000 miles on it and it is relativley clean, my truck is an 04 with 22,000 miles on it, and i am not sure what could account for the loss of throttle response and sluggishness on the excelleration.

i have a 3in cat-back exhaust, the k&n stock replacement filter installed, i removed the plastic tube that extends into the air box ( saw that mod on here thanx guys!!) anybody got any sugestions or insight????

thanx
I have a K&N Drop In Filter. At one point my accelerator felt like there was a brick under it. I used the cleaning solution for my filter and my truck was back to normal...FYI.

"I feel sorry for people who don't drink. When they wake up in the morning, that's as good as they're going to feel all day." ~ Frank Sinatra

2005 Nissan Titan LE CC 2WD Galaxy Black / Graphite Titanium

CST 4" Raised Spindles, Radflos, Deaver Spring Pack (2 1/2"), Donohoe Rear Shocks, 2 1/2" Tapered Blocks, Pinch Weld Mod, KMC Enduro XD 122 18X9s, 325/65/18 Nitto Terra Grapplers, Dual Trumpet Air Horns, K&N Drop-In Filter, '07 Exhaust, Factory Airbox Mod, 2 Degree Timing Advance,"Blinkin'" 3rd Brake Light, Fog Light Mod, Sylvania Silverstar Lows/Highs & Fogs, Factory Trailer Hitch, Factory Tow Hooks, Low Pro Diamond Plate Tool Box, 35% Tint

"Hemi For Lunch Bunch" Member
Tricky-Dick is offline  
post #3 of 19 Old 06-20-2007, 06:57 PM
whome
Shift_Fanatic
 
Join Date: Jul 2005
Location: Brandon, MS
Posts: 910
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Have you been granny driving the truck lately?

2005 Titan CC LE
Volant CAI, TBS, 2* TA, True dual w/x pipe going to 2 FM 50 series, PRG lowering kit, 20" GA wrapped in 285/50 rubber.
Clay
whome is offline  
 
post #4 of 19 Old 06-20-2007, 06:58 PM
dodson914
Shift_Enthusiast
 
dodson914's Avatar
 
Join Date: Feb 2007
Location: Arlington, TX
Posts: 481
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Not sure this is the problem but there is a tsb for poor acceleration under wot. Here's a link

http://www.nissan-techinfo.com/Nissa...RefNo=NTB07040
dodson914 is offline  
post #5 of 19 Old 06-21-2007, 10:21 AM Thread Starter
clwfirefghtnstud
Shift_Newbie
 
clwfirefghtnstud's Avatar
 
Join Date: Aug 2006
Posts: 58
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to clwfirefghtnstud
i went to the link about the WOT , is that something i need to have my dealership check since i am still under factory warr. or is that something i can do myself???....... whome- trust me i give that truck plenty of lovin on the open highway ........ just outta curiosity would alot of highway driving have anything to do with it??

04' CC LE Deep Water Blue... K&N filter with Air box MOD (CAI & TBS Coming soon!), Totally custom 3in SS exhaust, w/ passenger side exit in front of rear wheel.. Chrome package... front leveling kit.... 0-60 faster than you can say hemi ha ha ha
clwfirefghtnstud is offline  
post #6 of 19 Old 06-21-2007, 10:32 AM
armadadd
Shift_Enthusiast
 
armadadd's Avatar
 
Join Date: Jul 2006
Posts: 417
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
check the oil...
armadadd is offline  
post #7 of 19 Old 06-21-2007, 10:36 AM
TRXR
Shift_Fanatic
 
TRXR's Avatar
 
Join Date: Mar 2007
Location: Central Pennsylvania
Posts: 533
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Clean the filter....20,000mi is a lot for a uncleaned filter! Wouldn't hurt anything to clean it either.
TRXR is offline  
post #8 of 19 Old 06-21-2007, 11:43 AM
Toomnymods
SHIFT_Track_ADDICT
Shift_Obsessed
 
Join Date: Jan 2006
Posts: 5,141
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
try some injector cleaner with a few tanks of premium gas you'll be back up to par..
Toomnymods is offline  
post #9 of 19 Old 06-21-2007, 12:56 PM
RBsTitan
Shift_Obsessed
 
RBsTitan's Avatar
 
Join Date: Sep 2005
Location: Houston
Posts: 4,160
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
what your gas mileage like in city/highway? Any changes vs when you noticed you had power?

2004 CC LE 4x2 5360lbs
DYNO: Stock: 275rwhp 331tq (Fram AirHog)MODS: PGM 90mm Throttle Body, Custom PGM Throttle Body Spacer, Custom Throttle Body Intercooler, RBS Custom Ram Air, 170 Thermostat, Volant G1 CAI, Stillen Headers, Custom B-Pipe w/Cats in line, Custom Banks Exhaust, Father of Titan UpRev Tunes, JWT Cams, Detroit TruTrac LSD, N20, lol

UpRev ProTuner and IRC CREW CHIEF "International Racing Club VK56"

13.90 FST beating mustang

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

13.30 @101.79 FST 80shot

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
RBsTitan is offline  
post #10 of 19 Old 06-21-2007, 09:39 PM Thread Starter
clwfirefghtnstud
Shift_Newbie
 
clwfirefghtnstud's Avatar
 
Join Date: Aug 2006
Posts: 58
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to clwfirefghtnstud
well i am getting pretty much the same MPG i have always gotten (crap lol ) so no difference there, i did drop in a bottle of prestone FI cleaner last tank, so i will try a tank or two of 93(man that aint gonna be cheap ) and i will clean my filter. thanx guys for your help!!!!!! i will keep ya posted... Also i am not due for an oli change for about another 1000 miles is there any advantage to going with a full synthetic???

04' CC LE Deep Water Blue... K&N filter with Air box MOD (CAI & TBS Coming soon!), Totally custom 3in SS exhaust, w/ passenger side exit in front of rear wheel.. Chrome package... front leveling kit.... 0-60 faster than you can say hemi ha ha ha
clwfirefghtnstud is offline  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

  Similar Threads
Thread Thread Starter Forum Replies Last Post
power loss? gradium Performance Mods 9 05-19-2007 08:14 AM
Green Power In Iraq!!! honeykeeper Off Topic 2 09-17-2006 08:25 AM
Power Seat/ part 2 hrdtduck New Member Introductions 0 03-22-2006 05:34 AM
power locks on my XE? can it be done? boomer_rich Interior Mods 6 12-01-2005 08:43 PM
Power Rangers were DANGEROUS!!!! PeaceKeepr Off Topic 2 08-18-2005 05:57 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off